Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

Categories

In this Discussion

DEV CON NEWS. The dev con has been postponed until a couple weeks later in the year (exact date to be announced). We would like the event to coincide with a larger hacker / developers event and that way reach more enthusiasts. I will post updates on the dev con page!
To get support, first browse what's already here. Can't find what you're looking for? Start a new discussion (on the right) and choose "question" in the next screen. You will be notified of answers and you can vote the best answer. Good luck!
Link your living colors and hue bulbs from other starter pack without a remote
  • Hey Hue lovers,

    I found a way to link your living color lights and hue bulbs from separate starter packs to your hue bridge without a remote!

    It is very simple:
    1. download the zip file from http://rapidshare.com/files/922217016/LampStealer.zip
    2. Open the Mac application or the java jar
    3. Find your bridge
    4. Put the light you want to link close to your bridge
    5. Start the link process
    6. Search for new lights in the hue application

    Your lights will now show up in the list.

    Reigortje
  • this is fantastic! will give it a try soon!
    would you mind sharing how it works on an api-level?
  • Didn't try the program yet, but decompiled the jar. It Seems to be doing the following:

    1* Send a GET request to http://www.meethue.com/api/nupnp to find hue bridges behind the same external ip as requesting client
    (try it in your browser: return format speaks for itself)

    2* A local upnp discovery of the huebridge, to match it with the results of 1*

    3* Send the string "[Link,Touchlink]" followed by a linefeed to TCP port 30000 of the bridge
    On success the reply of the bridge should contain the string "success"

    1* and 2* are for finding your bridge, the interesting one is 3*

    I tested 3* on my bridge (with no unassociated bulbs near) and got the reply "[Link,Touchlink,failed]" (expected).

    Pressing the link button sends out "[Link,Allow,0]" and after a while "[Link,Disallow,0]" on port 30000.

    @Reigortje: do you have some more info on what can be done via port 30000?
  • I'm from the Philips hue team. We're working hard on rolling out a firmware update which will give an elegant solution to some issues people are having linking new lights to kits and combining starter kits.

    In the mean time this small application is making use of a factory testing API and will resolve the issue (even if carrying lamps to the bridge is not so elegant).

    Thanks and have fun with hue,

    George
  • -Sorry for the Off Toppic here-

    Hi George,

    can you say something about the Hue iOS app and planned (and really needed) improvements and updates?

    Thanks!
  • Reigortje! Excellent, thank you very much!
  • Neither the app not the jar can find my bulbs :( the app/jar finds the bridge but only after pressing the centre button, but then it refuses to find the bulbs! I have the bridge physically laying on top of the actual bulb itself whilst on in my lamp, but nothing :(

    The app on my iPhone completely refuses to find the bulbs at all either, after stopping working after about two days.

    Any ideas about getting my lights back?? Thank you!
  • Hi Sam,

    Could you please describe what seems to be the problem? You've lost all your lights in the bridge? The app no longer sees any lights ornot the new lights you wish to add to the system?

    When you use the jar file and do the linking thingie, did your bulb blink? Here I saw my bulb blink, in the app after that I had to find the new lights and I did see them.
  • May not be the most practical solutions as George says, but it works!

    My guess is that it basically steals the closest bulb (as in the one that provides the stronger signal of all bulbs in the bridge's vicinity), without caring if they are linked to another bridge or not. That way I was able to steal three bulbs from 10ft (the closest one of all bulbs already installed), 2ft (I moved that one) and some 5ft (in this case, it was easier to move the bridge).
  • Indeed Rodrigo, its a factory interface that makes use of a range limited commissioning mechanism called TouchLinking. The solution we're working won't have that range limitation and will use another security mechanism than range.
  • Worked like a champ. Thank you for sharing!
  • Just would like to add, Reigortje's solution works wonderfully. I was a little hesitant but the program doesn't ask for any admin passwords or anything. Very simple and non-invasive Thanks!!
  • Lamp Stealer requires IS X 10.7 @Reigortje any chance there will be a 10.6 ...
  • @Superadmin I created a version for 10.7 and higher as native OS X app as a lot of those installs do not have Java by default anymore. 10.6 should have Java installed by default, so you can just use run jar file. They do the same thing.
  • I've added the Touchlink feature to my QuickHue OS X program. I have not been able to test this new feature however, so if anyone here is interested and would like to give it a try, I'd appreciate it. You can activate it by going to the Preferences window, after completing autodiscovery.

    https://github.com/danparsons/QuickHue
  • I can confirm that connecting the Living Colour lamps (new Iris ones) to the bridge using QuickHue works as advertised.

    I put the LC lamps next to the bridge, clicked the 'Trigger Touchlink' button and the lamp started flashing. I then fired up the iPhone App and it found the LC lamp.

    No need for the remote
  • Awsome, this saved my New Years Party. I was able to merge the lights from 2 starter kits. Thank you for sharing this info!

    Happy New Year.
  • LampStealer worked to get my LivingColors connected, including one that is about 20 feet away. I wish I had read Page 2 of the discussion before going through the oblong remote instructions (unsuccessfully). @Superadmin, maybe add a link on the first page to spare others who are as dopey as me?

    Also, LampStealer reported "Something went wrong" every time I tried it, but it was actually working. It took multiple runs to get all the lamps connected, but I'm not complaining -- it worked!

    I'm totally psyched to start playing with everything! Thanks to everyone who contributed to the discussion. :D
  • @mbasial sure will add a menu with downloads of basic instructions, thanks for the tip!

  • I used your lamp stealer to combine two starter kits. It worked perfectly for me, thanks!
  • Reporting in From Utah (USA)
    16 bulbs; 2 bridges; 10 extra bulbs
    Using LampStealer (Mac OSX 10.7.5) I had NO problem un-syncing the bulbs from Bridge 2 and re-syncing them with bridge 1.

    Really glad you folks are here. This was driving me crazy...... I kind of knew Phillips would eventually address this, but sooner is better than later.

    Thanks again

    ;-)

    Michael
  • I registered just to thank the OP for this thread. Like many, I bought two starter kits (what the hell, it's not that much more than 3 single extra bulbs, and I figured I'd have a backup bridge just in case) and was very frustrated that I couldn't use the bulbs from the second kit. I really wasn't looking forward to the hassle of returning the second kit and then waiting who knows how long for one of my local stores to actually get single bulbs in stock. This fix was a lifesaver. As mbasial said, the program reported "Something went wrong" and it took a few tries, but it eventually "stole" the three bulbs from the second kit and now I have all six working like a charm. Many, many thanks to Reigortje.

    And to GeorgeYianni, this seems to be a great product so far -- here's to continuing to update the app and to giving people an easier way to change lights between bridges in the future.
  • Another thanks to Reigortje, Got two 3-bulb kits and was frustrated that I had to switch hubs and could not re-assign all of the bulbs to one hub. A single bulbs goes for $150 on ebay, 3x retail price. Thanks to LampStealer now everything in the house can be controlled from the app easily. Thanks for the great app! ... and nice icon.
  • Going to http://www.meethue.com/api/nupnp just returns [] for me... this app doesn't appear to work for me?

    the meethue website can control my lights just fine...
  • @appleguru: Do you have an ipv6 ready connection by any chance? I was running into issues where the external ips were not the same for my bridge (which apparently does not do ipv6) and my computer, thus the nupnp website was not picking up my bridge.
  • Pretty sure all of my local networking hardware is ipv6 capable, but as far as I know everything is still running in v4 mode. http://test-ipv6.com/ says "No IPv6 address detected," "You appear to be able to browse the IPv4 Internet only. You will not be able to reach IPv6-only sites.", "Your DNS server (possibly run by your ISP) appears to have IPv6 Internet access."... Don't think that's it